summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bf504ac710e..d786315b05e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,18 @@
-# Maintainer: Oscar Morante <spacepluk@gmail.com>
+# Maintainer: Valentijn "noirscape" V <neko at catgirlsin dot space>
+# Contributor: Felix Golatofski <contact at xdfr dot de>
+# Contributor: Oscar Morante <spacepluk at gmail dot com>
+
_prefix=/opt/UnityLts
+_hash=5da6f0345e82
+# hash obtained from: https://unity3d.com/unity/qa/lts-releases , you can find it by right clicking the download
+# link for any installer and then using your brain to figure out what part looks like the hash
pkgname=unity-editor-lts
-pkgver=2017.4.26f1
+pkgver=2019.4.24f1
pkgrel=1
epoch=1
-pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
+pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences. (LTS)"
arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
@@ -23,7 +29,8 @@ depends=('desktop-file-utils'
'libpqxx'
'npm'
'intel-tbb'
- 'gtk3')
+ 'gtk3'
+ 'python2')
optdepends=("${pkgname}-doc"
"${pkgname}-android"
"${pkgname}-ios"
@@ -31,17 +38,19 @@ optdepends=("${pkgname}-doc"
"${pkgname}-webgl"
"${pkgname}-windows"
"${pkgname}-facebook"
- "visual-studio-code-bin")
-source=("2017.4.26f1.tar.xz::https://download.unity3d.com/download_unity/3b349d10f010/LinuxEditorInstaller/Unity.tar.xz"
+ "visual-studio-code-bin"
+ "unityhub"
+ "jq: needed for UnityHub integration helpers --register/--deregister")
+source=("$pkgver.tar.xz::https://download.unity3d.com/download_unity/${_hash}/LinuxEditorInstaller/Unity.tar.xz"
"${pkgname}"
"${pkgname}.desktop"
"${pkgname}-icon.png"
"eula.txt")
-md5sums=("2706d97455571ce133c3467046ede54d"
- '6e2f0e897fe71d99c649f397dce8c0f9'
- '7cf8762a5f84a408286365d23fa00e5e'
- '723f9e556821810682a6d1f4be540a74'
- '7519f32fef332078cc77378fe9815835')
+sha256sums=('4e44fc8855caea35f0546a0d6b33d930bdc53d3ececba7bf37fbad08d003144e'
+ 'c22d2f91c47923496d24e8be376f70305846e60c038f923d6c7b41f0741bcb4a'
+ 'e786f76cfe96b41300775e54fcdd7e81dbfb3b28f607a263ac7a3a73a697ae06'
+ '193a3b88d7149f7eff19bbb282a836847831a842db399addbcc0cc600fd08cdb'
+ 'ad36e10abd6f4aa7dbd6619a57b521b067c96702b8f03a280245c60c2c1ebd1a')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package