summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 28 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cebdcd484246..a0b7561ccb20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# You must register at unrealengine.com and link your github account to access this private repo.
# @see https://wiki.archlinux.org/index.php/Unreal_Engine_4
-# The source is about 3.8 GiB, with an extra 3.2 GiB of dependencies downloaded in build(), and may take several hours to compile.
+# The source is about 3.78 GiB, with an extra 3.24 GiB of dependencies downloaded in build(), and may take several hours to compile. (sizes as of 4.12.1)
pkgname='unreal-engine'
pkgver=4.12.1
@@ -26,9 +26,9 @@ options=(!strip staticlibs)
build() {
cd $srcdir/UnrealEngine
- #./Setup.sh
- #./GenerateProjectFiles.sh
- #make
+# ./Setup.sh
+# ./GenerateProjectFiles.sh
+# make
}
package() {
@@ -36,19 +36,34 @@ package() {
cd $srcdir/UnrealEngine
+ # license
install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealEngine/LICENSE.pdf"
- install -d "$pkgdir/opt/$pkgname"
-
- install -d - "$pkgdir/opt/$pkgname"
-
- # copy the entire build dir, ~22 GiB
- # @todo only copy what is needed
- cp -r * "$pkgdir/opt/$pkgname/"
-
+ # engine
+ install -d "$pkgdir/opt/$pkgname/Engine"
# these folders needs to be writable, otherwise there is a segmentation fault when starting the editor
- chmod -R a+w "$pkgdir/opt/$pkgname/"
+ # @todo probably not all these folders need to be writable and/or installed, and maybe some should be moved to user's home
+ cp -r Engine/Binaries "$pkgdir/opt/$pkgname/Engine/Binaries"
+ cp -r Engine/Build "$pkgdir/opt/$pkgname/Engine/Build"
+ cp -r Engine/Config "$pkgdir/opt/$pkgname/Engine/Config"
+ cp -r Engine/Content "$pkgdir/opt/$pkgname/Engine/Content"
+ install -d "$pkgdir/opt/$pkgname/Engine/DerivedDataCache" # created when UE4Editor is run
+ cp -r Engine/Documentation "$pkgdir/opt/$pkgname/Engine/Documentation"
+ cp -r Engine/Extras "$pkgdir/opt/$pkgname/Engine/Extras"
+ install -d "$pkgdir/opt/$pkgname/Engine/Intermediate" # create without contents
+ cp -r Engine/Plugins "$pkgdir/opt/$pkgname/Engine/Plugins"
+ cp -r Engine/Programs "$pkgdir/opt/$pkgname/Engine/Programs"
+ cp -r Engine/Saved "$pkgdir/opt/$pkgname/Engine/Saved"
+ cp -r Engine/Shaders "$pkgdir/opt/$pkgname/Engine/Shaders"
+ install -d "$pkgdir/opt/$pkgname/Engine/Source" # create without contents
+ chmod -R a+rwX "$pkgdir/opt/$pkgname/Engine"
+
+ # content
+ cp -r FeaturePacks "$pkgdir/opt/$pkgname/FeaturePacks"
+ cp -r Samples "$pkgdir/opt/$pkgname/Samples"
+ cp -r Templates "$pkgdir/opt/$pkgname/Templates"
+ # icon for .desktop file
install -Dm644 Engine/Source/Programs/UnrealVS/Resources/Preview.png "$pkgdir/usr/share/pixmaps/UE4Editor.png"
}