summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b89df56b099..5bf360d21343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# The source is about 200 MiB, with an extra ~11 GiB of dependencies downloaded in Setup.sh, and may take several hours to compile.
pkgname=unreal-engine
-pkgver=4.26.1
-pkgrel=5
+pkgver=4.26.2
+pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=(x86_64)
url=https://www.unrealengine.com/
@@ -19,13 +19,11 @@ optdepends=('qt5-base: qmake build system for projects'
'clion: IDE for projects')
license=(custom:UnrealEngine)
source=(com.unrealengine.UE4Editor.desktop
- use-arch-mono.patch
clang_11.patch
PackageWithSystemCompiler.patch
ccache.patch
compile_and_regenerate.patch)
sha256sums=('15e9f9d8dc8bd8513f6a5eca990e2aab21fd38724ad57d213b06a6610a951d58'
- 'e891f07bf7294cd5fde8eb6de92e6d47ed004847ea8afd7c944e9b9b2bacaff4'
'8042bed3405298b5a4357068dd6b22a5a8a0f19def64b4f61ed0362fb46cb00d'
'9e403b939a0601c6271da17af9497742cacd74e3cde41562c9f288dfbdcbdbfe'
'a0a0d3f065e27f4d31e21e5f9d15cb4d8f59c50245a45469878fc1fe8bdc78e6'
@@ -37,6 +35,10 @@ _system_compiler= # for the system compiler you'll need to set LINUX_MULTIARCH_
# as an environment to /usr/sbin compile projects after building.
# The system compiler should work for everything in engine now.
_ccache_support= # Patches for ccache. More optimizations might be needed.
+_system_mono= # Uses System mono for unreal.
+ # must set UE_USE_SYSTEM_MONO
+ # in your environment for it to
+ # work after install
prepare() {
# Check access to the repository
@@ -58,7 +60,10 @@ prepare() {
git reset --hard $pkgver-release
fi
- patch Engine/Build/BatchFiles/Linux/SetupMono.sh $srcdir/use-arch-mono.patch # Use system mono
+ if [ -n "$_system_mono" ]
+ then
+ export UE_USE_SYSTEM_MONO=1
+ fi
generateProjectArgs="-makefile"
if [ -n "$_system_compiler" ]
then