summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24841be14245..98dd4cd31a34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,34 @@
# Mantainer: XenGi
pkgname=unrealtournament
pkgver=469b
-pkgrel=1
+pkgrel=3
pkgdesc="The classic Unreal Tournament from 1999 (Retail CD or DVD required)"
arch=('i686' 'x86_64')
url="http://www.unrealtournament.com/"
license=('custom')
groups=(ut1999-goty)
-[ "$CARCH" = "i686" ] && depends=(ossp libnotify sdl libgl)
-[ "$CARCH" = "x86_64" ] && depends=(ossp libnotify lib32-sdl lib32-libgl)
+[ "$CARCH" = "i686" ] && depends=(libnotify sdl libgl)
+[ "$CARCH" = "x86_64" ] && depends=(libnotify lib32-sdl lib32-libgl)
makedepends=(makepkg-unreal unshield lib32-fakeroot)
provides=(ut1999)
conflicts=(ut1999 ut ut-server)
-source=(ut436.run::"https://gitlab.com/XenGi/oldgames/-/raw/master/ut/unreal.tournament_436-multilanguage.run"
- ut436goty.run::"https://gitlab.com/XenGi/oldgames/-/raw/master/ut/unreal.tournament_436-multilanguage.goty.run"
+source=("ut436.run::https://gitlab.com/XenGi/oldgames/-/raw/master/ut/unreal.tournament_436-multilanguage.run"
+ "ut436goty.run::https://gitlab.com/XenGi/oldgames/-/raw/master/ut/unreal.tournament_436-multilanguage.goty.run"
"https://gitlab.com/XenGi/oldgames/-/raw/master/ut/ALAudio-86eade1c.zip"
"https://gitlab.com/XenGi/oldgames/-/raw/master/ut/OpenGLDrv-3.6-86eade1c.zip"
- "https://gitlab.com/XenGi/oldgames/-/raw/master/ut/UTPGPatch451.tar.bz2"
"https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v${pkgver}/OldUnreal-UTPatch${pkgver}-Linux.tar.bz2"
"ut.desktop"
"disk.list"
- "utpg.list"
"utcustom.sh"
"https://gitlab.com/XenGi/oldgames/raw/master/ut/ut.svgz")
-noextract=("UTPGPatch451.tar.bz2" "OldUnreal-UTPatch${pkgver}-Linux.tar.bz2")
+noextract=("OldUnreal-UTPatch${pkgver}-Linux.tar.bz2")
sha256sums=('8c0f0e266744ed18b14f6f6777d9ce8ed3ece120ccc37e7bbffa92e5a92ad2a8'
'cb704cf21625c12eaf181fabd24297bcf1f51576afa691067a56e3e6f38f6d34'
'674ae459b3ff6d442cce0e4b115244f3db5384923e6b848626aa67b370b7148b'
'b985a79323bee32ad24cce30afbfe63c47dcd43e3e06fa226b3ea42bbc4b0c0e'
- '31a07fb289841ceba36ca707fafd8180f48e462a53a62a2b34d5bc0f61c2481d'
'99b0832dfa5e8122b79c05b0d3cd22a277e36b865a1079941ee62c986cd92c1f'
'9aac034bbfe75afc1bbcc1f280025d6c36d77d4e00e68a3b11a2e3855f37756e'
'e31d9c7b91254128214dfa606058b78ece25a5a10fe2a2b8fd19575a9c7b2dbb'
- 'a079373b4a79c147e2a636593bb7490f656fc7f36ed4caa3cc1ba52ced4f32ff'
'ad9dca0d55bea773f573ff5f216c8010fd629c8785b6873a22c10172fbd10424'
'75ed2ef644f5e7100553241f195247dcad58d59a63b855d6895d421fdbfb9c1a')
@@ -152,20 +148,13 @@ _install_patches() {
tar xfC NetGamesUSA.com.tar.gz "${pkgdir}/opt/ut" || return 1
# As there is no distinction between GOTY and non-GOTY CDs yet, we just try
- # to patch everything that applies. Also Loki's patcher is too unreliable.
+ # to patch everything that applies. Also Loki's patcher is too unreliable.
cd "${srcdir}"
echo "Trying to apply Loki's 436 Xdelta patches..."
_unreal_fail_safe_patcher 436/setup.data/data "${pkgdir}/opt/ut"
_unreal_fail_safe_patcher 436goty/setup.data/data "${pkgdir}/opt/ut"
- echo "Applying 451 UTPG patch..."
- tar xfC UTPGPatch451.tar.bz2 451utpg || return 1
- _unreal_move_files 451utpg "${pkgdir}/opt/ut" < utpg.list || return 1
-
- # Fix a small bug until next UTPG release. Thanks for the hint, elsixdiab.
- sed -i '/^LoadClassMismatch/s/\.%s$//' "${pkgdir}/opt/ut/System/Core.int"
-
- echo "Applying latest OldUnreal patch"
+ echo "Applying OldUnreal patch"
tar xfC OldUnreal-UTPatch${pkgver}-Linux.tar.bz2 "${pkgdir}/opt/ut"
}