summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84985e2a3b56..aca68cdcba66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=unstickpixels
-pkgver=1
+pkgver=2
pkgrel=1
-pkgdesc='Screen loop to try to unstick stuck pixels'
-arch=(any)
-url='https://github.com/maandree/unstickpixels'
-license=(GPL3)
-depends=(python3 coreutils)
-makedepends=(texinfo gzip)
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=(78b2c47f8f4819624c310e5fc790d9a40055e0811d532a0d5db9a22b9c763299)
+pkgdesc="Screen loop to try to unstick stuck dots"
+arch=(i686 x86_64)
+url="https://github.com/maandree/unstickpixels"
+license=('GPL3' 'custom:GFDL1.3')
+depends=(glibc libgamma)
+makedepends=(glibc libgamma make coreutils gcc 'texinfo>=4.11')
+install=$pkgname.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(6f41482108a68b8a6deaefcb5d46d6fff4806947af463b717ce8b77cedaec97f)
build() {
- cd "${srcdir}/unstickpixels-${pkgver}"
- make
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
}
+
package() {
- cd "${srcdir}/unstickpixels-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "$srcdir/$pkgname-$pkgver"
+ make install N=: DESTDIR="$pkgdir"
}