summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f20151545f3..4ea0e835dce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname=unvanquished
pkgver=0.54.0
-pkgrel=3
+pkgrel=4
pkgdesc='A team-based, fast-paced, fps/rts hybrid game which pits aliens against humans.'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://www.unvanquished.net'
license=('GPL3')
makedepends=('cmake')
@@ -147,6 +147,11 @@ package() {
install -m 755 nacl_helper_bootstrap "${pkgdir}/usr/lib/unvanquished/"
install -m 755 nacl_loader "${pkgdir}/usr/lib/unvanquished/"
+ if [ "${CARCH}" == "aarch64" ]; then
+ install -m 755 nacl_helper_bootstrap-armhf "${pkgdir}/usr/lib/unvanquished/"
+ cp -r lib-armhf "${pkgdir}/usr/lib/unvanquished/"
+ fi
+
cd "${srcdir}/${_unvanquished}/dist/configs"
install -m 644 game/maprotation.cfg "${pkgdir}/etc/unvanquished/"