summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a78c2704589a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Naomi Phillips <naoph@cryptolab.net>
+pkgname=upl-git
+_pkgname=upl
+pkgver=0.1.r0.g042c169
+pkgrel=1
+epoch=1
+pkgdesc="A tiny script for uploading files to webservers over SSH"
+arch=('any')
+url="https://github.com/naoph/upl"
+license=('GPL')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=('python' 'python-yaml' 'scp')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/naoph/upl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 "upl" "$pkgdir/usr/bin/upl"
+}