summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f64d6299821..b766ed9b18b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+# Original Author: Grey Christoforo <first name [at] last name [dot] net>
-pkgname=uranium
-pkgver=15.06.03
+pkgname=uranium-git
+pkgver=15.06.03.655.g2e43338
pkgrel=1
pkgdesc="A Python framework for building Desktop applications."
url="https://github.com/Ultimaker/Uranium"
arch=('i686' 'x86_64')
-license=('GPLv3')
-depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'arcus')
-makedepends=('cmake')
-source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz" qt5.patch scripts.patch)
-md5sums=('60c583b462494c2de015a678ba134eb3'
- 'e4975dddd0524845b9574b4142274f5a'
- 'd1832c5533c1ab6ceffd0a70768ccbd6')
+license=('GPL3')
+provides=('uranium')
+conflicts=('uranium')
+depends=('python' 'qt5-quickcontrols' 'pyqt5-common' 'python-pyqt5' 'python-numpy' 'libarcus-git')
+makedepends=('cmake' 'git')
+source=('git+https://github.com/Ultimaker/Uranium.git' 'site-packages-dir.patch')
+md5sums=('SKIP' '104a4190a8df6b305801fefd0fb55387')
+
+pkgver() {
+ cd Uranium
+ git describe --tags | sed 's/-/./g'
+}
prepare(){
- cd Uranium-${pkgver}
- patch -Np1 -i ../qt5.patch
- patch -Np1 -i ../scripts.patch
+ cd Uranium
+ patch -Np1 -i ../site-packages-dir.patch
}
build() {
- cd Uranium-${pkgver}
- cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+ mkdir -p Uranium/build
+ cd Uranium/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd Uranium-${pkgver}
+ cd Uranium/build
make DESTDIR="${pkgdir}" install
- SITE_PACKAGES=$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
- mkdir -p "${pkgdir}${SITE_PACKAGES}"
- mv "${pkgdir}"/usr/lib/python3/dist-packages/* "${pkgdir}${SITE_PACKAGES}"/.
- rm -rf "${pkgdir}"/usr/lib/python3
+
#install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}