summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21209c2d5f37..d641895586e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: M Rawash <mrawash@gmail.com>
pkgname="urxvt-tabbedex-git"
-pkgver=20120216
+pkgver=20130612
pkgrel=1
-pkgdesc="Tabbed plugin for rxvt-unicode with many enhancements, development version"
+pkgdesc="Tabbed plugin for rxvt-unicode with many enhancements, git version with perl 5.18 patch."
arch=("any")
url='http://github.com/stepb/urxvt-tabbedex'
license=("GPL")
@@ -12,22 +12,22 @@ depends=('rxvt-unicode')
makedepends=('git')
provides=('urxvt-tabbedex')
conflicts=('urxvt-tabbedex')
-install=${pkgname}.install
+install=urxvt-tabbedex-git.install
+source=('git://github.com/stepb/urxvt-tabbedex.git'
+ '0001-make-urxvt-tabbedex-work-with-perl-5.18.patch')
+md5sums=('SKIP'
+ '92d581a40779da3127c88fdc7d10257f')
-_gitroot="git://github.com/stepb/urxvt-tabbedex.git"
-_gitname="urxvt-tabbedex"
-
-build() {
- msg "Connecting to ${_gitroot}..."
+pkgver() {
+ date +%Y%m%d
+}
- if [ -d ${srcdir}/${_gitname} ] ; then
- cd ${srcdir}/${_gitname} && git pull origin master
- else
- git clone $_gitroot
- fi
+prepare() {
+ cd ${srcdir}/urxvt-tabbedex
- msg "GIT checkout done or server timeout"
- msg "Starting Installation..."
+ git apply ../0001-make-urxvt-tabbedex-work-with-perl-5.18.patch
+}
- install -Dm644 ${srcdir}/${_gitname}/tabbedex ${pkgdir}/usr/lib/urxvt/perl/tabbedex
+package() {
+ install -Dm644 ${srcdir}/urxvt-tabbedex/tabbedex ${pkgdir}/usr/lib/urxvt/perl/tabbedex
}