summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40baeb965ff7..1773f718ec5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,19 +25,23 @@ url="https://graphics.pixar.com/usd/docs/index.html"
license=('Apache')
depends+=(boost{,-python2}-libs 'glew' 'openexr' 'opensubdiv')
makedepends+=(boost{,-python2} 'cmake' 'git' 'intel-tbb' 'ninja')
-conflicts=("usd")
provides=("usd=${pkgver}")
+conflicts=("usd")
source=("git+https://github.com/PixarAnimationStudios/USD.git${_fragment}"
"boost_python2.patch"
"blender.patch"
- "std.patch")
+ "std.patch"
+ "gcc11.patch"
+ "demangle-fix.patch")
sha256sums=('SKIP'
'2f595ce72b9fb33e6da7db97b02be11fe6262e31b83b0e59232ee8713afed97e'
'95a4934ae8154e1650a024b09ed3237ba7d9411ada089a4b6337cbba9312705a'
- '5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5')
+ '5e9dfc3daa97271b959e78737079335907a3536bb8af2d74ef9b8f7529f2f8e5'
+ '663352c8932a0b48230087284f4f5c540876f6a5adab3d4d1a7ee7b3a4ad6462'
+ '99ea5fba92842d0215e5188662a066e0cc714ed4dea9c8663cb6239f6c1afbd0')
prepare() {
- git -C USD apply -v "${srcdir}"/{boost_python2,blender,std}.patch
+ git -C USD apply -v "${srcdir}"/{boost_python2,blender,std,demangle-fix,gcc11}.patch
}
#pkgver() {