summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c9ee904cbc5..f35a0104f73b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Amr Hassan <amr.hassan@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Amr Hassan <amr.hassan@gmail.com>
pkgname=utf8cpp
-pkgver=2.3.4
-pkgrel=2
+pkgver=2.3.5
+pkgrel=1
pkgdesc="UTF-8 with C++ in a Portable Way"
url='http://utfcpp.sourceforge.net'
arch=('any')
license=('Custom')
-source=("http://downloads.sourceforge.net/project/utfcpp/utf8cpp_2x/Release%20${pkgver}/utf8_v${pkgver//./_}.zip")
-sha1sums=('638910adb69e4336f5a69c338abeeea88e9211ca')
+source=("https://github.com/nemtrif/utfcpp/archive/v${pkgver}.tar.gz")
+sha256sums=('f3ffe0ef6c02f48ebafe42369cbd741e844143baad27c13baad1cd14b863983d')
package() {
- cd "${srcdir}/source"
+ cd "utfcpp-${pkgver}/source"
install -d "${pkgdir}/usr/include"
for i in $(find . -type f); do install -Dm644 ${i} "${pkgdir}/usr/include/${i}"; done
}