aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e61f8ee756d..968490b52f1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,6 @@
# Contributor: tdy tdy@archlinux.info
pkgname=utopia-documents3
-pkgbase=utopia-documents
pkgver=3.0.0
pkgrel=1
pkgdesc="PDF reader that displays interactive annotations on scientific articles"
@@ -14,14 +13,14 @@ provides=('utopia-documents3')
conflicts=('utopia-documents')
depends=(libqglviewer pcre qt5-svg qt5-webkit qt5-script poppler-qt5 python2-pyqt5)
makedepends=(cmake boost swig glew)
-source=("http://utopiadocs.com/files/${pkgbase}-${pkgver}.tgz" "configure.patch")
+source=("http://utopiadocs.com/files/utopia-documents-${pkgver}.tgz" "configure.patch")
sha256sums=('1c259b68fada7f98080a66a63e36c707b78bfc3a5c80a956568ee73c030c8cac'
'808a26f259768507e864d729191b8dd85a6472f43d9c1f507dd775dd1eaedcc2')
prepare() {
PATCH="configure.patch"
-cd $pkgbase-$pkgver
+cd utopia-documents-$pkgver
patch configure ../$PATCH
./configure --release
@@ -35,11 +34,11 @@ cp CMakeCache.txt.1 CMakeCache.txt
}
build() {
- cd $pkgbase-$pkgver/build/Linux-Release
+ cd utopia-documents-$pkgver/build/Linux-Release
make -j4
}
package() {
- cd $pkgbase-$pkgver/build/Linux-Release
+ cd utopia-documents-$pkgver/build/Linux-Release
make install
}