summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90d79d897faf..ec25fa4ae5a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: Jordan Day <jordanday 4 4 4 at gmail dot com>
# Contributor: Jeff Cook <jeff@deserettechnology.com>
# Contributor: Michael Asher < michael at we solve every thing dot com >
# Contributor: William Díaz <wdiaz@archlinux.us>
-# Maintainer: adminempier <jl@adminempire.com>
+# Contributor: adminempier <jl@adminempire.com>
### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
### Please ask support questions about this software in one of:
### 1) The AUR comments; OR
@@ -13,23 +14,25 @@
### the software) then please do email me or post an AUR comment.
pkgname=uuid
+_pkgname=ossp-uuid
pkgver=1.6.2
-pkgrel=15
+pkgrel=16
pkgdesc="OSSP Universally Unique Identifier"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="http://www.ossp.org/pkg/lib/uuid"
license=('MIT')
depends=('sh')
options=('!libtool')
-source=("http://www.mirrorservice.org/sites/ftp.ossp.org/pkg/lib/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+source=("git+https://github.com/sean-/ossp-uuid.git"
"https://src.fedoraproject.org/rpms/uuid/raw/master/f/uuid-aarch64.patch"
ossp.patch)
-sha512sums=('16c7e016ce08d7679cc6ee7dec43a886a8c351960acdde99f8f9b590c7232d521bc6e66e4766d969d22c3f835dcc2814fdecc44eef1cd11e7b9b0f9c41b5c03e'
- '534ade47bf17531108d96c46bfc489b9fd4b1e7a66fcd903c8036210bdc6e631d591d04184e37b56c64ee74c05af799971d47d4cf30b25b45e05413319ae2f34'
- '36d0ea6088c12a5e382c3098f11214b202e96f91e4efd5cac567d5a81e836f78eeb654f051c576a211ec2dd5337b1f0a20d4246e84a0842fce22ae5fa96e5be9')
+sha512sums=('SKIP'
+ '534ade47bf17531108d96c46bfc489b9fd4b1e7a66fcd903c8036210bdc6e631d591d04184e37b56c64ee74c05af799971d47d4cf30b25b45e05413319ae2f34'
+ '36d0ea6088c12a5e382c3098f11214b202e96f91e4efd5cac567d5a81e836f78eeb654f051c576a211ec2dd5337b1f0a20d4246e84a0842fce22ae5fa96e5be9'
+)
build() {
- cd "${pkgname}"-"${pkgver}"
+ cd "${srcdir}/${_pkgname}"
# Rename because conflicts with util-linux
patch -p1 -i "${srcdir}"/ossp.patch
patch -p1 -i "${srcdir}"/uuid-aarch64.patch
@@ -38,7 +41,7 @@ build() {
}
package() {
- cd "${pkgname}"-"${pkgver}"
+ cd "${_pkgname}"
make DESTDIR="${pkgdir}" install
install -Dm644 README "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}