summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7482ad258995
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Akatsuki Rui <akiirui@outlook.com>
+
+pkgname=v2ray-domain-list-china
+pkgver=20210606164939
+pkgrel=1
+pkgdesc="A list of domains to be used as geosites for routing purpose in Project V"
+arch=('any')
+url="https://github.com/akiirui/domain-list-china"
+license=('MIT')
+source=("https://github.com/akiirui/domain-list-china/releases/download/$pkgver/dlc.dat"
+ "https://raw.githubusercontent.com/akiirui/domain-list-china/main/LICENSE")
+b2sums=('c660d02f5cb6d087390313145c73662d6dac0f2c95814092740e7c7df608fe0abca95b0a39813a68341a8737ad2cc0316d3fc954817b9ef556bb011fddfc3365'
+ '53fcf5b8a104ecd10a6719ef025de0d4779d1b24ea33a9b9dab78ae9f2579dc063c099e698745c6ac7b7e00bd5cbe5d849211f06281da9291fed86e193ae3628')
+
+package() {
+ install -Dm644 "$srcdir/dlc.dat" "$pkgdir/usr/share/v2ray/dlc.dat"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}