summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2d6e699146c..d511ad966282 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: mzz2017 <m@mzz.pub>
pkgname=v2raya
-pkgver=1.1.2
+pkgver=1.1.3
pkgrel=1
install=.INSTALL
-pkgdesc="A web GUI client of Project V which supports V2Ray, SS, SSR, Trojan and Pingtunnel protocols"
+pkgdesc="A web GUI client of Project V which supports VMess, VLESS, SS, SSR, Trojan and Pingtunnel protocols"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/v2rayA/v2rayA"
license=('GPL3')
@@ -23,7 +23,7 @@ build() {
cd "$srcdir/v2rayA-$pkgver/service"
export GO111MODULE=on
export GOPROXY=https://goproxy.io
- go build -ldflags="-X github.com/v2rayA/v2rayA/global.Version=$pkgver -s -w" -o v2raya
+ CGO_ENABLED=0 go build -ldflags '-X github.com/v2rayA/v2rayA/global.Version=$pkgver -s -w -extldflags "-static"' -o v2raya
}
package() {
@@ -31,6 +31,7 @@ package() {
install -Dm 755 service/v2raya -t "${pkgdir}"/usr/bin/
find web -type d -exec install -vd "${pkgdir}"/etc/v2raya/{} \;
find web -type f -exec install -vm 644 {} "${pkgdir}"/etc/v2raya/{} \;
+ install -dm 750 "${pkgdir}"/etc/v2raya/
install -Dm 644 install/universal/v2raya.desktop -t "${pkgdir}"/usr/share/applications/
install -Dm 644 install/universal/v2raya.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm 644 gui/public/img/icons/android-chrome-512x512.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/v2raya.png