summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7278a63d3e9..3e8775a41389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@
# Contributor: Timm Preetz <timm@preetz.us>
pkgname=vala-git
-pkgver=0.36.1
+pkgver=0.37.1
pkgrel=1
pkgdesc="Compiler for the GObject type system"
url="https://wiki.gnome.org/Projects/Vala"
arch=(i686 x86_64)
license=(LGPL)
depends=(glib2)
-provides=(vala)
-conflicts=(vala)
-makedepends=(libxslt git vala)
+provides=(vala valadoc)
+conflicts=(vala valadoc)
+makedepends=(libxslt git vala graphviz)
checkdepends=(dbus libx11 gobject-introspection)
source=("git+https://git.gnome.org/browse/vala")
sha256sums=('SKIP')
@@ -26,6 +26,8 @@ pkgver() {
prepare() {
cd ${pkgname/-git}
+ # patch -Np1 -i ../../gparamspecpointer.diff
+ # patch -Np1 -i ../../staticprivate.diff
NOCONFIGURE=1 ./autogen.sh
}
@@ -35,10 +37,10 @@ build() {
make
}
-check() {
- cd ${pkgname/-git}
- make check
-}
+# check() {
+# cd ${pkgname/-git}
+# make check
+# }
package() {
cd ${pkgname/-git}