summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 24 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 008a32026bf0..dbad37b97dae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,46 @@
-# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# $Id$
+# Maintainer: AdriĆ  Arrufat <adria.arrufat+AUR@protonmail.ch>
# Original Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
# Contributor: Timm Preetz <timm@preetz.us>
pkgname=vala-git
-pkgver=7142.cc038c1
+pkgver=0.34.0+48+g4797d90
pkgrel=1
pkgdesc="Compiler for the GObject type system"
+url="https://wiki.gnome.org/Projects/Vala"
arch=(i686 x86_64)
-url="http://live.gnome.org/Vala"
license=(LGPL)
depends=(glib2)
-makedepends=(git libxslt)
-provides=("vala=0.28.0")
-conflicts=(vala vala-devel)
-options=(!libtool)
-source=('git+git://git.gnome.org/vala')
-sha512sums=('SKIP')
+provides=(vala)
+conflicts=(vala)
+makedepends=(libxslt git vala)
+checkdepends=(dbus libx11 gobject-introspection)
+source=("git+https://git.gnome.org/browse/vala")
+sha256sums=('SKIP')
pkgver() {
- cd vala
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd ${pkgname/-git}
+ git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd vala
-
- git describe --tag | sed 's/-.*//g' > .tarball-version
+ cd ${pkgname/-git}
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd vala
-
- ./autogen.sh --prefix=/usr --enable-vapigen
+ cd ${pkgname/-git}
+ ./configure --prefix=/usr --enable-vapigen
make
}
-package() {
- cd vala
+check() {
+ cd ${pkgname/-git}
+ make check
+}
- make DESTDIR="${pkgdir}/" install
+package() {
+ cd ${pkgname/-git}
+ make DESTDIR="$pkgdir" install
}