summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebab1fb7a7a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: benwaffle <vala@iofel.me>
+# Maintainer: Prince781 <princetonferro@gmail.com>
+pkgname=vala-language-server
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Language Server for Vala'
+arch=('x86_64')
+url="https://github.com/benwaffle/vala-language-server"
+license=('LGPL-2.1')
+depends=('libgee' 'jsonrpc-glib' 'vala' 'meson')
+source=("https://github.com/benwaffle/vala-language-server/archive/$pkgver.tar.gz")
+sha256sums=('da82293234a36293f320a13feb59ab968ca1aabdbb9797c112114eaf836249e1')
+
+#prepare() {
+# cd "$pkgname"
+#}
+
+build() {
+ cd "$pkgname-$pkgver"
+ meson build --buildtype=release
+ ninja -C build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+