summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f08b4e31500a..ee4e71f8e9bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_plug=adaptivegrain
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=0.2.0.20.gcf9280a
+pkgver=0.2.0.22.g3307943
pkgrel=1
pkgdesc='Reimplementation of the adaptive grain mask as a Vapoursynth plugin'
arch=('x86_64')
url='https://git.kageru.moe/kageru/adaptivegrain'
license=('MIT')
depends=('vapoursynth')
-makedepends=('git' 'rustup')
+makedepends=('git' 'cargo')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("$_plug::git+https://git.kageru.moe/kageru/adaptivegrain.git")
@@ -22,6 +22,9 @@ pkgver() {
build() {
cd $_plug
+ echo 'If the build fails with “no default toolchain configured”, you may need to set up rust.
+When using rustup, this can be done via
+rustup install stable && rustup default stable'
cargo build --release --locked
}