summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9662712a48a9..23bc295bd25a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,16 @@ pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('any')
url='http://forum.doom9.org/showthread.php?t=168521'
license=('GPL')
-depends=('vapoursynth-plugin-histogram-git')
+depends=('vapoursynth'
+ 'vapoursynth-plugin-histogram-git'
+ )
source=('averagehist.py')
-sha1sums=('7180cdb099965cd9cf300afad41e23fff4da82f6')
+sha256sums=('728334aa284a87c123c1d4a91b6ec826c07c46d56754532743d6e18cc60d01de')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
package(){
- install -Dm644 averagehist.py "${pkgdir}${_sites_packages}/averagehist.py"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}