summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4479b09db251
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=cnr2
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.gefbc438
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=173659"
+license=('GPL')
+depends=('vapoursynth'
+ )
+makedepends=('git'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha1sums=('SKIP')
+options=('!makeflags')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}