summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8128b25a069d..ced966422206 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=dfmderainbow
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v2.0.g22faeb5
+pkgver=2.2.g44dc654
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url="https://github.com/dubhater/vapoursynth-${_plug}"
license=('GPL')
-depends=('vapoursynth'
- 'vapoursynth-plugin-temporalmedian-git'
+depends=('vapoursynth-plugin-temporalmedian-git'
'vapoursynth-plugin-temporalsoften2-git'
- 'vapoursynth-plugin-fluxsmooth-git'
+ 'vapoursynth-plugin-fluxsmooth'
'vapoursynth-plugin-msmoosh-git'
'vapoursynth-plugin-minideen-git'
- )
-optdepend=('vapoursynth-plugin-mvtools-git'
- 'vapoursynth-plugin-fft3dfilter-git'
+ 'vapoursynth-plugin-mvtools'
+ 'vapoursynth-plugin-fft3dfilter-git'
)
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
@@ -24,11 +22,11 @@ conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
-_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')"
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
package(){