summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa36ff678a5d..1754e883742b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=dither
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=20150223.0f209b6
+pkgver=r19.0f209b6
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
@@ -13,18 +13,17 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/IFeelBloated/VaporSynth-Functions.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
+
_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
#echo "$(git describe --long --tags | tr - .)"
- echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package(){
- cd "${_gitname}"
- install -Dm644 Dither.py "${pkgdir}${_sites_packages}/Dither.py"
+ install -Dm644 "${_plug}/Dither.py" "${pkgdir}${_sites_packages}/Dither.py"
}