summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 24 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31c6fa92f357..d71c6f6f886d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,37 @@
_plug=havsfunc
pkgname=vapoursynth-plugin-${_plug}
pkgver=r21
-pkgrel=1
+pkgrel=3
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('any')
url='http://forum.doom9.org/showthread.php?t=166582'
license=('GPL')
-depends=('vapoursynth')
+depends=('vapoursynth-plugin-addgrain-git'
+ 'vapoursynth-plugin-awarpsharp2-git'
+ 'vapoursynth-plugin-bilateral-git'
+ 'vapoursynth-plugin-ctmf-git'
+ 'vapoursynth-plugin-dctfilter-git'
+ 'vapoursynth-plugin-deblock-git'
+ 'vapoursynth-plugin-dfttest-git'
+ 'vapoursynth-plugin-eedi2-git'
+ 'vapoursynth-plugin-fft3dfilter-git'
+ 'vapoursynth-plugin-flash3kyuu_deband-git'
+ 'vapoursynth-plugin-fluxsmooth'
+ 'vapoursynth-plugin-fmtconv'
+ 'vapoursynth-plugin-genericfilters-git'
+ 'vapoursynth-plugin-knlmeanscl'
+ 'vapoursynth-plugin-mvtools'
+ 'vapoursynth-plugin-nnedi3'
+ 'vapoursynth-plugin-sangnommod-git'
+ 'vapoursynth-plugin-scenechange'
+ 'vapoursynth-plugin-temporalsoften-git'
+ )
makedepends=('git')
-optdepends=('vapoursynth-plugin-addgrain-git: for QTGMC function (optional)'
- 'vapoursynth-plugin-awarpsharp2-git: for YAHR function'
- 'vapoursynth-plugin-bilateral-git: for logoNR function'
- 'vapoursynth-plugin-ctmf-git: for HQDeringmod function'
- 'vapoursynth-plugin-dctfilter-git: for Deblock_QED function'
- 'vapoursynth-plugin-deblock-git: for Deblock_QED function'
- 'vapoursynth-plugin-dfttest-git: for QTGMC function (optional)'
- 'vapoursynth-plugin-eedi2-git: for santiag function'
- 'vapoursynth-plugin-fft3dfilter-git: for QTGMC function (optional)'
- 'vapoursynth-plugin-flash3kyuu_deband-git: for SmoothLevels function'
- 'vapoursynth-plugin-fluxsmooth: for logoNR function'
- 'vapoursynth-plugin-fmtconv: for QTGMC function'
- 'vapoursynth-plugin-genericfilters-git: for HQDering function'
- 'vapoursynth-plugin-knlmeanscl: for QTGMC function (optional)'
- 'vapoursynth-plugin-mvtools: for QTGMC, GrainStabilizeMC and LSFmod function'
- 'vapoursynth-plugin-nnedi3: for QTGMC function'
- 'vapoursynth-plugin-sangnommod-git: for santiag function'
- 'vapoursynth-plugin-scenechange: for QTGMC function'
- 'vapoursynth-plugin-temporalsoften-git: for TemporalSoften function'
- )
-source=("https://dl.dropbox.com/u/6596386/vapoursynth-plugins/${_plug}-${pkgver}.7z")
-sha1sums=('d71683c92cfa0a1408c439af3452c2b4bb6a964e')
+source=("${_plug}-${pkgver}.tar.gz::https://github.com/HomeOfVapourSynthEvolution/havsfunc/archive/${pkgver}.tar.gz")
+sha1sums=('0d6ca515f61361f8b4d4b85a25d74ceaa116856f')
_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
package() {
- install -Dm644 "${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}-${pkgver}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
}