summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cf0ea8a2fcf..c29966166182 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,16 @@ arch=('any')
url="https://github.com/AzraelNewtype/${_plug}"
license=('GPL')
depends=('vapoursynth'
- 'mkvtoolnix'
+ 'mkvtoolnix-cli'
)
makedepends=('git')
+optdepends=('mkvtoolnix-gui: Graphical interface for Mkvtoolnix')
provides=("vapoursynth-tools-${_plug}")
conflicts=("vapoursynth-tools-${_plug}")
source=("${_plug}::git+https://github.com/AzraelNewtype/${_plug}.git")
sha256sums=('SKIP')
-_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')"
pkgver() {
cd "${_plug}"
@@ -31,6 +32,6 @@ package(){
python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
- install -Dm644 example.vpy "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/example.vpy"
+ install -Dm644 example.vpy "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/example.vpy"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}