summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a40777434d4..c1f125493573 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: vantu5z <vantu5z@mail.ru>
pkgname=vasisualy-git
-pkgver=0.6.2
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc="Vasisualy is a simple Russian voice assistant written on python 3 for GNU/Linux and Windows."
arch=('i686' 'x86_64')
url="https://github.com/Oknolaz/vasisualy"
@@ -13,12 +13,14 @@ depends=('rhvoice' 'speech-dispatcher'
'python-geocoder'
'python-lxml'
'python-mss'
+ 'python-plyer'
'python-pyaudio'
+ 'python-pyalsaaudio'
'python-pyowm'
'python-pyqt5'
+ 'python-pyqt5-webengine'
'python-qt-material'
'python-scipy'
- 'python-shell'
'python-sounddevice'
'python-speechrecognition'
'python-translate'
@@ -29,9 +31,11 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=($pkgname::'git+https://github.com/Oknolaz/vasisualy.git'
${pkgname}-pi::'git+https://github.com/Oknolaz/vasisualy-pi.git'
- ${pkgname}-files::'git+https://github.com/Oknolaz/vasisualy-additional-files.git')
+ ${pkgname}-files::'git+https://github.com/Oknolaz/vasisualy-additional-files.git'
+ ru_w2n::'git+https://github.com/Oknolaz/Russian_w2n.git')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -45,6 +49,9 @@ build() {
cd "${srcdir}/${pkgname}-pi"
python setup.py build
+
+ cd "${srcdir}/ru_w2n"
+ python setup.py build
}
package()
@@ -62,4 +69,8 @@ package()
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm0755 "run.py" "${pkgdir}/usr/bin/vasisualy-pi"
install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}-pi/LICENSE"
+
+ cd "${srcdir}/ru_w2n"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm0644 LICENSE.txt "${pkgdir}/usr/share/licenses/ru_w2n/LICENSE"
}