summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3787f497b2d..ef4609185432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@
pkgname=vcsh
pkgver=1.20190619
-pkgrel=1
+pkgrel=2
pkgdesc='Version Control System for $HOME that manages multiple Git repositories'
arch=('any')
url="https://github.com/RichiH/$pkgname"
license=('GPL')
depends=('git')
-optdepends=('myrepos: helps manage a large number of repositories')
makedepends=('ruby-ronn')
checkdepends=('perl' 'perl-shell-command')
+optdepends=('myrepos: helps manage a large number of repositories')
source=("$pkgname-$pkgver.tar.gz::https://github.com/RichiH/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('9f9373bd96dfa1317ff119b2a3feaffc0e5331816e940267daf088637f995f5f')
@@ -23,6 +23,11 @@ prepare() {
sed -i 's#^\(install:\) all#\1 manpages#' Makefile
}
+build() {
+ cd "$pkgname"
+ make manpages
+}
+
check() {
cd "$pkgname-$pkgver"
make test