summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 903e7eda25fb..b28e4cb46988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,11 @@ options=(!buildflags)
source=("https://www.lrde.epita.fr/dload/vcsn/$pkgver/$pkgname-$pkgver.tar.xz")
md5sums=('48e479d34a047df4507d1e7b322bfb16')
+check() {
+ cd "$srcdir/${_realname}"
+ ./tests/bin/vcsn python -c 'import vcsn; vcsn.B.expression("a").automaton()'
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix="/usr" CXXFLAGS='-O3' CPPFLAGS='-DNDEBUG'