summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index edcf9c3b5e4f..e71a6661241e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Miroslav Koškár <http://mkoskar.com/>
-_rackver=0.5.1
+_rackver=0.6.0
_plugname='AudibleInstruments'
pkgname='vcvrack-audible-instruments'
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="Mutable Instruments' VCV modules"
url='https://github.com/VCVRack/AudibleInstruments'
license=(BSD)
arch=(i686 x86_64)
-depends=(vcvrack)
-makedepends=(git)
+depends=('vcvrack>=0.6')
+makedepends=(git zip)
+install="$pkgname.install"
source=(
"vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
@@ -19,7 +20,6 @@ source=(
AndrewBelt-eurorack::git+https://github.com/AndrewBelt/eurorack.git
git+https://github.com/AndrewBelt/osdialog.git
git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/mackron/dr_libs.git
git+https://github.com/memononen/nanosvg.git
git+https://github.com/memononen/nanovg.git
git+https://github.com/pichenettes/avr-audio-bootloader.git
@@ -41,13 +41,11 @@ sha256sums=(
SKIP
SKIP
SKIP
- SKIP
)
prepare() {
cd vcvrack
git submodule init
- git config submodule.ext/dr_libs.url "$srcdir/dr_libs"
git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
git config submodule.ext/nanovg.url "$srcdir/nanovg"
git config submodule.ext/osdialog.url "$srcdir/osdialog"
@@ -74,13 +72,11 @@ prepare() {
build() {
cd "vcvrack/plugins/$_plugname"
- make
+ FLAGS='-I/opt/vcvrack/include' make dist
}
package() {
cd "vcvrack/plugins/$_plugname"
- install -D -m644 -t "$pkgdir/usr/share/licenses/vcvrack/$_plugname" LICENSE*
- install -d "$pkgdir/opt/vcvrack/plugins/$_plugname"
- cp -dr --preserve=mode -t "$pkgdir/opt/vcvrack/plugins/$_plugname" \
- res plugin.so
+ install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
+ "$pkgdir/opt/vcvrack/$_plugname.zip"
}