summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac237564d84f..32aeac80ecec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-dvbapi
-pkgver=2.2.4
+pkgver=2.2.4_4_g7d51cc4
epoch=1
-_vdrapi=2.2.0
-pkgrel=2
+_gitver=7d51cc457823156d446d06c6ae40f850958fa735
+_vdrapi=2.4.0
+pkgrel=1
pkgdesc="A bridge between VDR and OScam."
url="https://github.com/manio/vdr-plugin-dvbapi"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -13,18 +14,23 @@ license=('GPL2')
depends=('gcc-libs' 'libdvbcsa' 'openssl' "vdr-api=${_vdrapi}")
makedepends=('git')
_plugname=${pkgname//vdr-/}
-source=("https://github.com/manio/vdr-plugin-dvbapi/archive/v$pkgver.tar.gz")
+source=("git+${url}.git#commit=${_gitver}")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-sha256sums=('0014cd9fbf40d10f630c4aa9b2e60c9dca44d4cdab27529da3e47be9a9c01e13')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git describe --tags | sed 's/-/_/g;s/v//'
+}
build() {
- cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}"
sed -i 's/ -fdiagnostics-color=auto//g' Makefile
make LIBDVBCSA=1
}
package() {
- cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}"
make LIBDVBCSA=1 DESTDIR="$pkgdir" install
mkdir -p "$pkgdir/etc/vdr/conf.avail"