summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bf52f5d6b37..2245d5558df9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=2.3.1
epoch=1
_gitver=e582514ede475574842b44ca6792335ff141172d
_vdrapi=2.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Adds the possibility to control VDR and some of it's plugins by a web interface."
url="http://projects.vdr-developer.org/projects/plg-live"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -14,15 +14,25 @@ license=('GPL2')
depends=('pcre' 'tntnet' "vdr-api=${_vdrapi}")
optdepends=('vdr-epgsearch: Manage searchtimers'
'vdr-streamdev: Stream live TV')
-makedepends=('git')
+makedepends=('git' 'patchutils')
install="$pkgname.install"
_plugname=${pkgname//vdr-/}
source=("git://projects.vdr-developer.org/vdr-plugin-live.git#commit=$_gitver"
+ 'https://projects.vdr-developer.org/attachments/download/2186/v2-0004-Add-ability-to-play-stream-by-external-media-player.patch'
+ 'https://projects.vdr-developer.org/attachments/download/2187/0005-Remove-support-for-VLC-NPAPI-plugin-and-replace-it-w.patch'
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
md5sums=('SKIP'
+ '14152d6ddc14d5ec39473f92ca1c1f78'
+ 'ea8187d1e51fbc1a48767ac6eb0f33d2'
'563961eb90d9f2b3d2a0a34472ef51ee')
+prepare() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ filterdiff -x '*.po' ${srcdir}/v2-0004-Add-ability-to-play-stream-by-external-media-player.patch | git apply -
+ filterdiff -x '*.po' ${srcdir}/0005-Remove-support-for-VLC-NPAPI-plugin-and-replace-it-w.patch | git apply -
+}
+
pkgver() {
cd "${srcdir}/vdr-plugin-${_plugname}"
git describe --tags | sed -e 's/release_//g' -e 's/-/\./' -e 's/-/\./' -e 's/-/_/g'