summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d0d74732725..35edc803a768 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,27 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-osdteletext
-pkgver=0.9.5
-_vdrapi=2.2.0
-pkgrel=4
+pkgver=0.9.7
+_vdrapi=2.4.0
+pkgrel=2
pkgdesc="Displays teletext pages directly on VDR's OSD"
url="http://projects.vdr-developer.org/projects/plg-osdteletext"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('gcc-libs' "vdr-api=${_vdrapi}")
+optdepends=('ttf-teletext2: renderng special graphic characters used in Teletext')
_plugname=${pkgname//vdr-/}
source=("http://projects.vdr-developer.org/git/vdr-plugin-$_plugname.git/snapshot/vdr-plugin-$_plugname-$pkgver.tar.bz2"
- "0001-Use-internal-cBitmap-for-drawing-instead-of-getting-.diff::https://www.vdr-portal.de/index.php?attachment/39352"
+ 'remove-blank-lines.patch::https://www.vdr-portal.de/index.php?attachment/41771'
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-md5sums=('5e578b222ab55c3e7fffd06a1b0a306d'
- '870f1f7834b906a5ee1e7f1c2289e27e'
+md5sums=('3cc9318b3b5d63884320b57e2268648c'
+ '14d8bd880d82f3a86705ca94ed8aac84'
'4e47fd8f77cea06d30e07486b7fd9d6e')
prepare() {
cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
- patch -p1 -i "$srcdir/0001-Use-internal-cBitmap-for-drawing-instead-of-getting-.diff"
+ patch -p1 -i "${srcdir}/remove-blank-lines.patch"
}
build() {