summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83d98f60abe6..05abc28799dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,15 @@ license=(GPL2)
depends=(vegastrike-engine)
makedepends=(git cmake)
options=(!strip)
-source=("git+https://github.com/vegastrike/Assets-Production#tag=v${pkgver}")
+source=("Vega-Strike-Assets-Production::git+https://github.com/vegastrike/Assets-Production#tag=v${pkgver}")
sha256sums=('SKIP')
build(){
- cmake -DCMAKE_INSTALL_PREFIX=/usr "${srcdir}"/Assets-Production/CMakeLists.txt
+ cmake -B build -S "Vega-Strike-Assets-Production" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
}
package() {
- make -C "${srcdir}" DESTDIR="${pkgdir}" install
+ DESTDIR="$pkgdir" cmake --install build
}
-