summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e62b3fe6b53..497274ccf26d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,30 @@
# Contributor: moostik <mooostik_at_gmail.com>
pkgname=veusz
-pkgver=3.2.1
+pkgver=3.3.1
pkgrel=1
pkgdesc="A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output"
arch=('x86_64')
url="https://veusz.github.io/"
license=('GPL2')
depends=('python-pyqt5' 'python-numpy' 'python-sip' 'hicolor-icon-theme')
-makedepends=('sip')
+makedepends=('sip5')
optdepends=('python-h5py: HDF5 support'
# 'pyemf >= 2.0.0: EMF export https://github.com/jeremysanders/pyemf (Python 3 port in development) - package missing
'python-dbus: dbus interface'
'python-iminuit: improved fitting'
'python-astropy: VO table import and FITS import'
'ghostscript: for EPS/PS output')
- # patch from https://github.com/veusz/veusz/issues/307
-source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz"
- "veusz-${pkgver}-sip_dir.patch")
-sha256sums=('9eaf95a2a8cae2d317e7ee47e73f5cf58d191b16c051ae0a1dc399e6f7757503'
- '334700cb64638fb4710e3049fe26d7b97abafc24581ad949b110e5d07567d31f')
+source=("https://github.com/veusz/veusz/releases/download/veusz-${pkgver}/veusz-${pkgver}.tar.gz")
+sha256sums=('e02960630894db5c070ef7b6abd708b520156fd85b47617e7c973cce7188f0e0')
-prepare() {
- patch -Np1 -i "veusz-${pkgver}-sip_dir.patch"
-}
build() {
cd "${pkgname}-${pkgver}"
- python setup.py build_ext --sip-dir=/usr/lib/python3.8/site-packages/PyQt5/bindings/
+ [[ -d NEW ]] || mkdir -p NEW
+ [[ -d NEW/PyQt5 ]] && rm -rf NEW/PyQt5
+ ln -s /usr/lib/python3.9/site-packages/PyQt5/bindings/ NEW/PyQt5
+ export SIP_DIR=NEW/
python setup.py build
}