summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD113
1 files changed, 63 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bee2d4b0721..b7c1379e1289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,78 @@
# Maintainer: sgar <swhaat in github>
pkgname=veyon
-pkgver=4.2.1
+pkgver=4.8.3
pkgrel=1
-pkgdesc="Open Source computer monitoring and classroom management"
-arch=('i686' 'x86_64')
-url="https://github.com/veyon"
-license=('GPLv2')
-depends=('qt5-base'
- 'libxrandr'
- 'libxtst'
- 'pam'
- 'pam_ldap'
- 'openssl'
- 'libjpeg-turbo'
- 'zlib' 'qca-qt5'
- 'libqtxdg'
- 'lzo'
- 'libxinerama')
+pkgdesc="Cross-platform computer monitoring and classroom management"
+arch=('x86_64')
+url="https://veyon.io/"
+license=('GPL2')
+depends=('hicolor-icon-theme' 'libfakekey' 'libjpeg-turbo' 'libldap' 'libsasl'
+ 'libvncserver' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext'
+ 'libxfixes' 'libxinerama' 'libxrandr' 'libxtst' 'lzo' 'openssl' 'pam'
+ 'procps-ng' 'qca-qt6' 'qt6-base')
+makedepends=('clang' 'cmake' 'git' 'qt6-declarative' 'qt6-httpserver' 'qt6-tools')
optdepends=('kldap: KDE support')
-makedepends=('git' 'cmake' 'qt5-tools')
-source=("git+${url}/veyon.git#tag=v${pkgver}"
- "git+${url}/ultravnc.git"
- "git+${url}/libvncserver.git"
- "git+${url}/x11vnc.git"
- "git+git://anongit.kde.org/kldap.git")
+_commit=fd8f0ba1e5c1025e71abcebec5f17a186096b610 # tags/v4.8.3
+source=("git+https://github.com/veyon/veyon.git#commit=${_commit}"
+ 'git+https://github.com/veyon/ultravnc.git'
+ 'git+https://invent.kde.org/pim/kldap.git'
+ 'git+https://github.com/veyon/libvncserver.git'
+ 'git+https://github.com/veyon/x11vnc.git'
+ 'git+https://github.com/veyon/libfakekey.git'
+ 'git+https://github.com/veyon/qthttpserver.git'
+ 'git+https://github.com/nodejs/http-parser.git'
+ 'git+https://github.com/novnc/noVNC.git'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
prepare() {
- mkdir -p build
- for file in ultravnc libvncserver x11vnc kldap
- do
- cp -a --no-preserve=ownership "${srcdir}/$file" "${srcdir}/${pkgname}/3rdparty/"
- done
- cd "${pkgname}"
- git submodule update --init
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.3rdparty/ultravnc.url "$srcdir/ultravnc"
+ git config submodule.3rdparty/kldap.url "$srcdir/kldap"
+ git config submodule.3rdparty/libvncserver.url "$srcdir/libvncserver"
+ git config submodule.3rdparty/x11vnc.url "$srcdir/x11vnc"
+ git config submodule.3rdparty/libfakekey.url "$srcdir/libfakekey"
+ git config submodule.3rdparty/qthttpserver.url "$srcdir/qthttpserver"
+ git config submodule.3rdparty/kldap-qt-compat.url "$srcdir/kldap"
+ git -c protocol.file.allow=always submodule update
+
+ pushd 3rdparty/qthttpserver
+ git submodule init
+ git config submodule.src/3rdparty/http-parser.url "$srcdir/http-parser"
+ git -c protocol.file.allow=always submodule update
+ popd
+
+ pushd 3rdparty/libvncserver
+ git config submodule.webclients/novnc.url "$srcdir/noVNC"
+ git -c protocol.file.allow=always submodule update
+ popd
}
build() {
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_VEYON_X11VNC_EXTERNAL=ON \
- -DSYSTEMD_SERVICE_INSTALL_DIR=/usr/lib/systemd/system/ \
- -DCMAKE_BUILD_TYPE=release \
- ../"${pkgname}"
- make
+ cmake -B build -S "$pkgname" \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DSYSTEMD_SERVICE_INSTALL_DIR='/usr/lib/systemd/system' \
+ -DWITH_QT6=ON -DVEYON_DEBUG=ON \
+ -Wno-dev
+ cmake --build build
}
package_veyon() {
- cd build
- make DESTDIR="${pkgdir}" install
-
- cd ${pkgdir}/usr/lib/${pkgname}
- for lib in $(ls *.so)
- do
- ln -s "/usr/lib/veyon/$lib" "${pkgdir}/usr/lib/$lib"
- done
+ DESTDIR="$pkgdir" cmake --install build
}