summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11ee451ae4e6..c2c250fdb265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
# Container: gbr <gbr@protonmail.com>
-_pkgname=vibrantlinux
-pkgname=${_pkgname}
-pkgver=2.1.0
+pkgname=vibrantlinux
+pkgver=2.1.1
pkgrel=1
pkgdesc="A tool to automate managing your screen's saturation depending on what programs are running"
arch=(x86_64)
url="https://github.com/zee-mzha/vibrantLinux"
license=('MIT')
-depends=("qt5-base" "libxnvctrl" "vibrant" "hicolor-icon-theme")
+depends=("qt5-base" "libvibrant.so=1" "hicolor-icon-theme")
makedepends=("git")
-conflicts=("vibrantlinux")
-provides=("vibrantlinux")
-source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git#tag=v${pkgver}"
+source=("${pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git#tag=v${pkgver}"
"vibrantLinux.desktop")
sha512sums=('SKIP'
'21531277bbcea2ab65116f8420db9197f99801f34f934f9bd181fb2077c3c26337c7356df236783a53eee6dccc3e994f7992c9aaa8d53ca32ec0d98231357b1f')
build() {
- cd "${_pkgname}"
+ cd "${pkgname}"
qmake
make ${MAKEFLAGS}
}
package() {
- cd "${_pkgname}"
+ cd "${pkgname}"
make INSTALL_ROOT="${pkgdir}" install
@@ -35,7 +32,8 @@ package() {
do
install -Dm664 "assets/icon${res}.png" "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vibrantLinux.png"
done
+
install -Dm644 "${srcdir}/vibrantLinux.desktop" "${pkgdir}/usr/share/applications/vibrantLinux.desktop"
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}