summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a32f15c0be4..837f03823494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,28 @@ pkgname=vibrantlinux-git
pkgrel=1
pkgdesc='vibranceGUI replacement for Linux'
arch=('x86_64')
-url='https://github.com/zee-mzha/vibrantlinux'
+url='https://github.com/libvibrant/vibrantlinux'
license=('MIT')
depends=('qt5-base' 'libvibrant')
makedepends=('git')
conflicts=('vibrantlinux')
provides=('vibrantlinux')
-source=("${_pkgname}::git+https://github.com/zee-mzha/vibrantLinux.git")
+source=("$_pkgname::git+$url.git")
sha256sums=('SKIP')
-pkgver=2.1.1.r10.g3ddb88f
+pkgver=2.1.7.r0.ga75092b
pkgver() {
- cd "${_pkgname}"
-
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_pkgname}"
-
- qmake
- make
+ cd "$_pkgname"
+ qmake
+ make
}
package() {
- cd "${_pkgname}"
-
- make INSTALL_ROOT="${pkgdir}" install
-
- mv "${pkgdir}/usr/share/applications/application.desktop" "${pkgdir}/usr/share/applications/vibrantLinux.desktop"
+ cd "$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
}