summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fd6d17344ee..09869aaaffcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Benjamin Hodgetts <ben@xnode.org>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Benjamin Hodgetts <ben@xnode.org>
pkgname=vice-svn
-pkgver=r34920
+pkgver=r38195
pkgrel=1
-pkgdesc="The Versatile Commodore Emulator (Commodore 64/C64)."
+pkgdesc="The Versatile Commodore Emulator (Commodore 64/C64). - Development version"
arch=('i686' 'x86_64')
url="http://vice-emu.sourceforge.net"
license=('GPL')
depends=('giflib' 'lame' 'libjpeg' 'libpng' 'libxrandr' 'libnet' 'libpcap' 'xdialog')
-makedepends=('xorg-font-utils' 'pkg-config')
+makedepends=('pkg-config' 'xa' 'svn' 'texlive-core' 'dos2unix')
optdepends=('pulseaudio' 'pulseaudio-alsa' 'alsa-lib')
provides=('vice')
replaces=('vice')
-source=("${pkgname}::svn://svn.code.sf.net/p/vice-emu/code/trunk" 'vice-fixes.patch')
-md5sums=('SKIP' '6ae696148e372bcdc7aa21e4fc39e5d2')
+conflicts=('vice-sdl2' 'vice-svn-gtk3' 'vice-svn-sdl2')
+source=("${pkgname}::svn://svn.code.sf.net/p/vice-emu/code/trunk")
+sha256sums=('SKIP')
pkgver() {
echo r$(svnversion "${SRCDEST}"/${pkgname}/)
}
-prepare() {
- cd "${pkgname}/vice"
- patch -Np1 -i ../../vice-fixes.patch
-}
-
build() {
- cd "${pkgname}/vice"
- ./autogen.sh
- ./configure --prefix=/usr --without-oss --without-alsa --enable-native-gtk3ui
- make
+ cd "${pkgname}/vice"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --enable-external-ffmpeg \
+ --enable-x64
+ make
}
package() {