summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d705b478a16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Martchus <martchus@gmx.net>
+pkgname=videodownloader
+pkgver=1.0.8
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A video downloader with Qt GUI (currently only YouTube is maintained)."
+license=('GPL')
+depends=('qtutilities' 'openssl')
+makedepends=('qt5-tools')
+install=${pkgname}.install
+url="https://github.com/Martchus/videodownloader"
+source=("videodownloader-${pkgver}.tar.gz::https://github.com/Martchus/videodownloader/archive/v${pkgver}.tar.gz")
+_reponame=videodownloader
+sha256sums=('skip')
+
+build() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ INSTALL_ROOT=$pkgdir/usr/ qmake-qt5 "$pkgname.pro"
+ make
+}
+
+package() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make install
+}