summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28b2ac87a3b3..bda56e820d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# maintainer: libele <libele@disroot.org>
pkgname=vilearn
-pkgver=1.0
-pkgrel=7
+pkgver=1.0.1
+pkgrel=1
pkgdesc="An interactive vi tutorial."
-url="https://web.archive.org/web/20020806204039/http://vilearn.org/"
-license=('custom')
arch=('any')
+url="https://web.archive.org/web/20020806204039/http://vilearn.org/"
+license=('custom:Copyright (c) 1992 Jill Kliger and Wesley Craig')
+optdepends=('vi: the original ex/vi text editor')
-source=("https://archive.org/download/vilearn/vilearn"{-1.0.tar.gz,.diff})
+source=('https://archive.org/download/vilearn/vilearn-1.0.tar.gz'
+ "https://tildegit.org/libele/vilearn/archive/vilearn-$pkgver.tar.gz")
md5sums=('8fd3b72e5eb1e4dce1870e7b3becbeab'
- '39975f4064c59c30545f6f070fc85cc6')
+ 'fdfba9fde37af73cbde0f83724cd3713')
package() {
cd "${srcdir}"
- patch -d vilearn-1.0 < vilearn.diff
+ patch -d vilearn-1.0 < vilearn/vilearn-1.0.1.patch
cd vilearn-1.0
make DESTDIR=${pkgdir} install
install -Dm644 README "${pkgdir}"/usr/share/vilearn
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/vilearn/LICENSE
}