summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e15986f12a98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=vim-diffchar
+pkgver=6.2
+pkgrel=1
+pkgdesc="Improve vim's diff mode, by finding exact differences between lines, character by character"
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=4932'
+license=('unknown')
+depends=('vim')
+groups=('vim-plugins')
+install=vimdoc.install
+source=("$pkgname-$pkgver.zip::http://www.vim.org/scripts/download_script.php?src_id=24319")
+sha256sums=('4e24267f8c9510365b5ee2e70e873e78ea0bcdc88e69eb21ec612180998cfdf3')
+
+prepare() {
+ rm doc/tags
+}
+
+package() {
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ mkdir -p "${_installpath}"
+ cp -r autoload doc plugin "${_installpath}"
+# install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}