summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3a1aa59da2a..e5b9df532f90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=vim-fortran
_filename=fortran.vim
pkgver=0.4
_scriptid=15717
-pkgrel=1
+pkgrel=2
pkgdesc="Additional indentation rules for Fortran 95 and Fortran 90"
arch=(i686 x86_64)
url="http://www.vim.org/scripts/script.php?script_id=2299"
@@ -12,18 +12,18 @@ license=('custom')
depends=('vim')
groups=('vim-plugins')
install=vimdoc.install
-source=(${pkgname}::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
-md5sums=('2dd6ae6ff44facee2f673b898482679b')
+source=(${_filename}::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+sha256sums=('d3c67714ed9248397b513366126e1dc61f6bd2081c96849a8ea5f0a0282662f9')
prepare(){
- cd $srcdir
+ cd "${srcdir}"
#Fix some encoding stuffs
- iconv -f ISO_8859-16 -t UTF8 $pkgname > ${_filename}.bak
- tr -d '\015' < ${_filename}.bak > ${_filename}
- rm ${_filename}.bak
+ iconv -f ISO_8859-16 -t UTF8 ${_filename} > ${_filename}.new
+ tr -d '\015' < ${_filename}.new > ${_filename}.new.new
}
package(){
- install -Dm755 ${srcdir}/${_filename} ${pkgdir}/usr/share/vim/vimfiles/after/indent/$_filename
+ install -Dm755 "${srcdir}/${_filename}.new.new"\
+ "${pkgdir}/usr/share/vim/vimfiles/after/indent/${_filename}"
}