summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..732269be93d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: yesuu zhang <yesuu79@qq.com>
+# Contributor: exul <exul [at] v-net [dot] ch>
+
+pkgname=vim-go-git
+pkgver=20150710
+pkgrel=1
+pkgdesc='Go development plugin for Vim'
+arch=('any')
+url='https://github.com/fatih/vim-go'
+license=(unknown)
+conflicts=('vim-go' 'vim-gocode' 'gocode-git')
+depends=('go' 'vim')
+makedepends=('git')
+source=('git+https://github.com/fatih/vim-go.git')
+md5sums=(SKIP)
+
+package() {
+ cd "${srcdir}/vim-go/"
+ install --directory "${pkgdir}/usr/share/vim/vimfiles/"
+ for dir in autoload/ compiler/ doc/ ftdetect/ ftplugin/ gosnippets/ indent/ plugin/ scripts/ syntax/; do
+ cp --recursive "${dir}" "${pkgdir}/usr/share/vim/vimfiles/"
+ done
+}