summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e25029132e01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Peter Varo <hello@petervaro.com>
+
+pkgname=vim-multiple-cursors-git
+pkgver=latest
+pkgrel=1
+pkgdesc="True Sublime Text style multiple selections for Vim"
+arch=('any')
+url="https://github.com/terryma/vim-multiple-cursors"
+license=('MIT')
+groups=('vim-plugins')
+makedepends=('git')
+install='vimdoc.install'
+source=("git://github.com/terryma/vim-multiple-cursors.git")
+md5sums=('SKIP')
+
+package() {
+ cd "vim-multiple-cursors"
+ _installpath="$pkgdir/usr/share/vim/vimfiles"
+ install -Dm755 doc/multiple_cursors.txt "$_installpath/doc/multiple_cursors.txt"
+ install -Dm755 plugin/multiple_cursors.vim "$_installpath/plugin/multiple_cursors.vim"
+ install -Dm755 autoload/multiple_cursors.vim "$_installpath/autoload/multiple_cursors.vim"
+ install -Dm644 MIT-LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+