summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c95cf6ae125..924d9cdcb93c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,22 @@
pkgname=vim-python-mode
_pkgname=python-mode
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc='A vim plugin that make vim into python IDE'
arch=('any')
license=('LGPL3')
url='https://github.com/python-mode/python-mode'
-depends=('vim' 'python' 'python-astroid' 'autopep8' 'python-mccabe' 'python-pycodestyle' 'python-pydocstyle' 'python-pyflakes' 'python-pylint' 'python-rope' 'python-six' 'python-snowballstemmer')
+depends=('vim' 'python' 'python-astroid' 'autopep8' 'python-mccabe' 'python-pycodestyle' 'python-pydocstyle' 'python-pyflakes' 'python-pylint' 'python-rope' 'python-six' 'python-snowballstemmer' 'pylama')
#pylama' '
groups=('vim-plugins')
-source=("https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('1d0812ebfe5850b298502c37ceff1b30cb492550995f0c9612a0a8df09f17d9f')
-
+source=("https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz"
+ "1-fix-pylama-linters.patch")
+sha256sums=('1d0812ebfe5850b298502c37ceff1b30cb492550995f0c9612a0a8df09f17d9f'
+ '9f7bc8e24c1a4fe2f1e158e69817f57805f25f81802b7b056d06603f7c38dc22')
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -p1 -i ../1-fix-pylama-linters.patch
+}
package() {
cd "${_pkgname}-${pkgver}"