summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2d04fb123e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Cravix <dr dot neemous at gmail dot com>
+# Based on community/vim-jedi PKGBUILD by Levente Polyak <anthraxx[at]archlinux[dot]org>
+# check part doesn't work so directly removed it :p if you know how to fix it please tell me :)
+
+pkgname=vim-python-mode
+_pkgname=python-mode
+pkgver=0.9.2
+pkgrel=1
+pkgdesc='A vim plugin that make vim into python IDE'
+arch=('any')
+license=('LGPL3')
+url='https://github.com/python-mode/python-mode'
+depends=('vim' 'python')
+optdepends=('python-pylint' 'python-rope')
+groups=('vim-plugins')
+source=("https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=(1dffe0cd0f70e0a1d55196fe885426fc13e1c89d15047f73aaf85b037c651fbd)
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ install -d "${pkgdir}/usr/share/vim/vimfiles"
+ cp -dpr --no-preserve=ownership pymode "${pkgdir}/usr/share/vim/vimfiles"
+ cp -dpr --no-preserve=ownership after "${pkgdir}/usr/share/vim/vimfiles/after"
+ cp -dpr --no-preserve=ownership autoload "${pkgdir}/usr/share/vim/vimfiles/autoload"
+ cp -dpr --no-preserve=ownership doc "${pkgdir}/usr/share/vim/vimfiles/doc"
+ cp -dpr --no-preserve=ownership ftplugin "${pkgdir}/usr/share/vim/vimfiles/ftplugin"
+ cp -dpr --no-preserve=ownership plugin "${pkgdir}/usr/share/vim/vimfiles/plugin"
+ cp -dpr --no-preserve=ownership syntax "${pkgdir}/usr/share/vim/syntax"
+
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}