summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c69c36f039f..1174026c8367 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
pkgname=ranger-vim
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Ranger integration for vim"
license=('MIT')
arch=('any')
url="https://github.com/francoiscabrol/ranger.vim"
depends=('vim' 'ranger')
groups=('vim-plugins')
-source=("https://github.com/francoiscabrol/${pkgname/-/.}/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/francoiscabrol/${pkgname/-/.}/archive/${pkgver}.tar.gz")
md5sums=('59f24462eb5c7561756a646585cd9e4c')
package() {
- install -Dm755 "${srcdir}/${pkgname/-/.}-${pkgver}/plugin/ranger.vim" \
+ install -Dm755 "${pkgname/-/.}-${pkgver}/plugin/ranger.vim" \
"${pkgdir}/usr/share/vim/vimfiles/plugin/ranger.vim"
+
+ head -n 22 "${pkgname/-/.}-${pkgver}/plugin/ranger.vim" > LICENSE
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}