summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5666790f07f..d9d2c585b2ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
+_pkgname=vim-scripts
pkgname=vim-systemd
-pkgver=20170410
+pkgver=r34.7c4724d
pkgrel=1
pkgdesc="ViM syntax highlighting for systemd unit files"
arch=("any")
-url="http://fedorapeople.org/cgit/wwoods/public_git/vim-scripts.git/"
-license=('unknown')
+#url="http://fedorapeople.org/cgit/wwoods/public_git/${_pkgname}.git/"
+url=https://github.com/wgwoods/${_pkgname}
+license=('GPL')
depends=('vim')
-source=("git+https://fedorapeople.org/cgit/wwoods/public_git/vim-scripts.git")
+makedepends=('git')
+#source=("git+https://fedorapeople.org/cgit/wwoods/public_git/${_pkgname}.git")
+source=("git+https://github.com/wgwoods/${_pkgname}.git")
md5sums=('SKIP')
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package () {
- cd vim-scripts
+ cd ${_pkgname}
install -Dm0644 ftdetect/systemd.vim "$pkgdir"/usr/share/vim/vimfiles/ftdetect/systemd.vim
install -Dm0644 ftdetect/udev.vim "$pkgdir"/usr/share/vim/vimfiles/ftdetect/udev.vim
install -Dm0644 syntax/systemd.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/systemd.vim