summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8ac221fc416
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Liao Junxuan <mikeljx at 126 dot com>
+pkgname=vim-zoom
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="Toggle zoom in / out individual windows (splits)"
+arch=("any")
+url="https://github.com/dhruvasagar/vim-zoom"
+depends=(vim)
+license=("MIT")
+
+source=($pkgname-$pkgver.tar.gz::"${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('5ad53b9d1dab364870b9ce8a33aaf9dd423ce0190b65e36fc41f543b4ce21610')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -d "${_installpath}"
+ find autoload doc plugin -type f -exec \
+ install -Dm 644 '{}' "${_installpath}/{}" \;
+}