summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc3b7228931e..e0651189e00a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,18 @@
# Note: I hope wael is a nice woman now :troll:
pkgname=vinegar
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio"
arch=("x86_64")
url="https://github.com/vinegarhq/vinegar"
license=("GPL3")
depends=("glibc" "hicolor-icon-theme")
-makedepends=("git" "go" "mingw-w64-gcc")
+makedepends=("git" "go")
optdepends=("wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar-git")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=("2b19e08fe0566e63483444ebc1d8d07dc8161a921b069a0175ef5798f6e96698")
+sha256sums=("eb3476b8de6a76b585206bb5fe901d74980de24b3c5c8e4c59598b0b25276f2b")
build() {
cd "${pkgname}-${pkgver}"
@@ -25,14 +25,14 @@ build() {
# Make sure Vinegar rebuilds
make clean
- make VERSION="${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" vinegar robloxmutexer
+ make VERSION="${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" all
}
package() {
cd "${pkgname}-${pkgver}"
# This does all the work (except for the optional LICENSE file)
- make DESTDIR="${pkgdir}" PREFIX="/usr" install install-robloxmutexer
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
# Install GPLv3 license (just in case)
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"